För en vecka sedan upptäckte utvecklaren Tim Perry en allvarlig sårbarhet i ett populärt Javascript-bibliotek som används i mängder av program.

Med hjälp av sårbarheten, som fått beteckningen CVE-2021-23406, kan hackare köra skadlig kod på datorer som har något eller några av de berörda programmen installerade.

Sårbarheten har täppts till i version 5.0 av Pac-Resolver, Pac-Proxy-Agent och Proxy-Agent, vilket innebär att alla utvecklare som har använt sig av tidigare versioner uppmanas att uppdatera sina program så snart som möjligt.

Enligt uppgift har Pac-Resolver fler än tre miljoner nedladdningar per vecka, något som ger en fingervisning om hur många program som berörs.

Vill du veta mer om sårbarheten kan du surfa vidare till HTTP Toolkit.